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How To Produce an eBook 

By !omas Burkert

When Smashing Magazine started as a professional English-language online 
magazine for Web designers in September 2006, there were initially no 
plans to also publish eBooks. The idea of publishing Smashing eBooks 
came up the first time in February 2010 during the production of our printed 
Smashing Book. We realized that the production and distribution costs of a 
printed book are high. We thought, “Wouldn't it be a good idea to also 
publish eBooks in addition to our printed book?”

We didn’t wait long to make this idea happen. The production of Smashing 
eBook #1 began immediately in February 2010 and was published soon 
thereafter in March 2010 as a PDF version. It contained the best articles 
about professional Web design that had been published on Smashing 
Magazine in 2009 and 2010.

!ere are three eBook Formats
The EPUB format currently is supported by a wide variety of eBook readers. 
As the industry standard, eBooks you buy today in EPUB format without 
DRM are most likely to be supported on the widest variety of readers in the 
future. E-Book readers that cannot read EPUB format usually read the 
Mobipocket format.

If you own a Kindle, the PDF and Mobipocket formats are your only choices. 
A PDF will almost certainly be more difficult to read on almost every eBook 
reader than one of the other formats. A PDF is designed to preserve layout 
and font size across devices. It was neither designed to re-flow text to fit the 
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screen of a variety of different eBook readers nor to scale fonts for easier 
reading.

The PDF format is usually best for printing out paper copies of a book, 
because the original layout will be preserved the best. A PDF can also be 
easy to read on a sufficiently large laptop or computer screen.

EPUB

EPUB (electronic publication) is a relatively new open eBook standard that 
was introduced by the Open eBook Forum of the International Digital 
Publishing Forum (IDPF) in late 2007. The EPUB specification is a 
distribution and interchange format standard for digital publications and 
documents. EPUB defines a means of representing, packaging and 
encoding structured and semantically enhanced Web content — including 
HTML5, CSS, SVG, images, and other resources — for distribution in a 
single-file format. The standard is supported by over 150 major companies, 
including Adobe, Apple, Google, Microsoft, Nokia, Hewlett-Packard and 
Sony.

At the time of writing, the IDPF EPUB Working Group has published the 
Proposed Specification for final member and public review for EPUB 3. 
These new specifications will increase the format’s capabilities in order to 
better support a wider range of publication requirements, including complex 
layouts, rich media and interactivity, and global typography features. The 
expectation is that EPUB 3 will be utilized for a broad range of content, 
including books, magazines and educational, professional and scientific 
publications.

Mobipocket

The Mobipocket eBook format is based on the older Open eBook 
Publication Standard (OEBPS), which was superseded by EPUB in 2007. It 
uses XML and XHTML to store and represent book content. The name 
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comes from the company Mobipocket SA, which produces Mobipocket 
Reader, a free eBook reader for PDAs, smartphones and mobile operating 
systems such as Symbian, Windows, Mobile, Palm OS, webOS, Java ME, 
BlackBerry, Psion and Amazon Kindle. There are also readers for desktop 
computers running Microsoft Windows and Mac OS X. At the time of writing, 
Amazon Kindle cannot read EPUB eBooks unless some intermediary 
software converts the books into a format that the Kindle can understand.

PDF (Portable Document Format)

PDF was originally a proprietary standard but since 2008 has been an open 
standard. Developed by Adobe, it was initially created as a standard for 
storing and editing printable publishable documents. PDF documents can 
be displayed by many eBook readers too.

Because the format was originally designed to reproduce fixed page 
layouts, the text generally cannot be reflowed to fit the screen. As a result, 
PDF files that are designed to be printed on a standard paper size are less 
comfortable to read on eBook readers, especially ones that are small or low 
in resolution, such as mobile phones.

Most publishers offer their eBooks in one or more of the formats covered 
above. Finding current statistics on the market share of these three formats 
is difficult. O'Reilly tracks which of these formats customers download after 
buying a book, and the company has broken it down over 16 months, from 
July 2007 to November 2009. According to these statistics, PDF continues 
to be the most popular format, but EPUB is becoming more popular.

Creating eBooks with Apple Pages
As we continued to produce more Smashing eBooks, we have been always 
looking for better authoring tools. After experimenting with various tools, we 
have decided to use Apple Pages as our preferred authoring tool.
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Apple Pages allows us to generate all three major eBook formats (PDF, 
EPUB, Mobipocket) within minutes from one single source document. EPUB 
export functionality was added to Apple Pages with version 9.0.4. Based on 
the EPUB file, the Mobipocket version of our eBooks can be easily 
generated with KindleGen.

Page Size and Document Margins

When you start your eBook project you should first define the page size and 
document margins. The document page size and margins are primarily 
needed for the layout of your PDF eBook. EPUB and Mobipocket do not 
make use of these parameters. US Letter (612 pt x 792 pt) is a good paper 
size format to start with, because it makes best use of the 4:3 screen ratio 
that is most common for tablet computers. The following screenshot of 
Apple Pages Inspector Window shows the parameters that are used for the 
Smashing eBooks. Open the Inspector by clicking on its icon on the toolbar 
or choose View > Show Inspector.
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Inspector Window: Document

Use Paragraph Styles

The best document consistency between PDF and EPUB format can be 
obtained by strictly using paragraph styles. A sample document which can 
be used as a template is provided on the Apple Support site. It features 
styles and guidelines to help you create a Pages document that’s optimized 
for exporting to the EPUB file format. To learn more about using paragraph 
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styles in Pages, see the topics under the heading “Working with Styles” in 
the Pages built-in help.

Paragraph Styles in Apple Pages

Table of Contents (TOC)

Apple Pages can automatically generate a table of contents for your eBook. 
To create a Table of Contents (TOC) in Apple Pages, you need to 
consistently use paragraph styles for headings in your document. In the 
Inspector Window, select the paragraph styles whose text should appear in 
the table of contents as shown in the screenshot below.
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Heading 1 selected for TOC (Inspector Window > Table of Contents)

The selected paragraph styles will then be automatically added to the Table 
of Contents section in your EPUB eBook. If you want to add a Table of 
Content to your PDF eBook, choose Insert > Table of Contents. 

Note: Manually inserted Table of Contents (Insert>Table of Contents) will 
work in PDF only and not in your EPUB eBook. You should temporarily 
delete this Table of Contents before you export your document to the EPUB 
format.
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Embedding Images

Reformat any images in your document to make them Inline Objects. Do not 
make them Floating Objects, because floating objects will not be exported 
to the EPUB eBooks. To learn more about inline objects, see “What Are 
Floating and Inline Objects?” in the Pages Help.

Images must be Inline Objects

Cover Image

Apple Pages can use the first page as the cover image for the eBook. Place 
an image on the first page and make it a Floating Object. This is the only 
exception where you can use an image as a Floating Object. In the 
Inspector Window, go to Metrics and set the image size to 612 x 792 pt and 
the positions to 0.
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Exception: Make the cover image a floating object

How to Use Tables

Although EPUB and Mobipocket reader can handle tables that are larger 
than the screen, the user experience becomes worse as the table size 
increases. You should avoid large tables. A table with up to 3 columns will 
work well on most screens, even on smartphones. But you should avoid any 
tables that have more than 3 columns.
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Not Supported by EPUB

Note that some content is currently not supported by the EPUB file format 
standard and will be removed from your document when exporting as an 
EPUB file with Apple Pages:

• Smart-fields

• Master/Background objects

• Headers and footers

• Floating graphics

• Footnotes (converted to endnotes)

• Columns

• Comments

• Some image effects such as shadows

• Images beyond the 11MB of unencoded image data allocated per 
chapter

Export PDF and EPUB

You can export any Apple Pages word processing document to PDF and 
EPUB file formats. Choose File > Export.

The EPUB export screen asks you to type in metadata about your eBook 
such as Title, Author and Genre. You can also choose if the first page should 
be used as cover image.

Smashing eBook│How to Produce an eBook│ 12



EPUB export with Apple Pages

Your document will then be exported as an EPUB file to your hard drive. The 
EPUB file is automatically compliant with EpubCheck, a tool that can detect 
many types of errors in EPUB.

Converting to Mobipocket

KindleGen is a command line tool used to build eBooks that can be sold 
through Amazon's Kindle platform. This tool is best for publishers who want 
to convert their existing EPUB eBook into a Kindle Book. After you have 
downloaded the KindleGen tool, you then need to open the Terminal on 
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Mac OS X and submit the command ./kindlegen followed by the filename of 
your EPUB file. Assuming the KindleGen tool and your EPUB file are in the 
same folder, the complete command would be: 

./kindlegen five-smashing-years.epub

After submitting this command, KindleGen will compile a Mobipocket file 
based on your existing EPUB file. During the compilation KindleGen will 
display information such as that shown below:

KindleGen output during compilation

Workflow: 15 Steps To A New Smashing eBook
Planning, producing and publishing a Smashing eBook with 15 articles from 
various authors and usually more than 300 pages is a complex task. From 
the first idea to a finished Smashing eBook, we have to go through many 
steps each time. People with different skills need to work hand in hand in 
order to ensure high quality and to meet deadlines. 

Since we have produced our first Smashing eBooks in Spring 2010, we have 
learned a lot. We have studied different eBook formats. We have explored 
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different authoring tools that are available and evaluated which tools fit our 
individual requirements best. And we have optimized our production 
workflow. 

Workflow Planning for Smashing eBook #4 (September 2010)

The following section will give you an overview of our 15 step workflow, that 
we have implemented for the production of our Smashing eBook Series.

Planning (Week 1)

Step 1: Define eBook Title

• Find a crisp and short eBook title that will attract people’s attention.
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Step 2: Define Table of Contents

• Bookmark all articles that relate to the topic using Firefox Bookmark 
Manager. 

• Prioritize and select the articles based on the quality and on the 
communities feedback. 

• Order chapters and articles in a way that make sense.

Production (Week 2-4)

Step 3: Paste Articles into Apple Pages

• Copy and paste articles from www.smashingmagazine.com into Apple 
Pages using Apple Safari.

Step 4: Format Headings, Paragraphs, Lists

• Improve productivity by using paragraph styles and keyboard shortcuts 
for most often used paragraph styles.

• Use Apple Pages Pagination & Break options for formatting. Do not use 
empty lines or manual line breaks for formatting. This could cause 
unwanted formatting results, especially in EPUB and Mobipocket files.
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Pagination & Break options using Apple Pages Inspector 

Step 5: Optimize Screenshots

• Make screenshots with the keyboard shortcut SHIFT-CTRL-CMD-4 and 
paste it in Apple Pages with CMD-V. Use GIF for screenshots with text, 
logos, line drawings and icons. Use JPG for photographs. 

• Change the Mac OS X default format (PNG) by executing one of the 
following commands in the Mac OS X Terminal. (Logout and login again 
to activate the changes)

defaults write com.apple.screencapture type jpg
defaults write com.apple.screencapture type gif

Step 6: Update Biographies of Authors

• Give the authors the possibility to update their biography and the links 
to their Web pages, Facebook Pages and Twitter accounts.
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Step 7: Validate Hypertext Links

• Check if all hypertext links in the eBook are valid. Click on Action menu 
at the bottom of the window and select Hyperlink and then click the 
blue scroll arrows.

Action menu and scroll arrows

Step 8: Export eBooks

• Export your PDF eBook with Image Quality “Best” (compression level 
100%) or “Better” (compression level 90%).

• Export your EPUB eBook with the option Use first page as book cover 
image selected.

Step 9: Create Zip-File

• Create a Zip-File that includes all three formats. Use Mac OS X built-in 
compression functionality. Select all three files, then click on Menu Files 
> Compress 3 Items.
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Step 10: Design eBook Cover

• Find a good designer for your eBook cover. A well designed eBook 
cover will help to sell the eBook.

• Starting the design of the eBook cover as early as possible can help to 
meet deadlines. Designing a cover is a creative process that can take 
some time until the final version is available.

• An eBook cover with a short title and big letters is good for thumbnails.

Step 11: Test on Different Devices

• Test PDF, ePub and Mobipocket formats after the first chapter has been 
finished. Early testing can give valuable feedback on how formatting will 
look like on different devices. This will save time during the production 
of the other chapters. 

• Free software eBook readers such as Adobe Digital Editions (ePub) or 
Kindle for Mac (Mobi) can be also used for testing.
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Testing Smashing eBooks on various eBook readers

Step 12: Spell checking and Proofreading

• Use Apple Pages Spell checking feature.

• Ask the proofreader to do his corrections in the PDF version using 
Adobe Reader X comments functionality. Adobe Reader is available on 
Windows and Mac OS.
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Commenting feature in Adobe Reader X

Publishing (Week 5)

Step 13: Inform Support Team

• Inform support team about the new Smashing eBook and send them a 
copy of the ebook. The support team can then help customers who 
have problems downloading the eBook.

Step 14: Publish Product

• Upload eBook as .zip file to the Smashing Shop
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• Make screenshots from the eBook on an iPad and then add them to the 
product page.

Step 15: Do Marketing

• Market the eBook on the Web, Facebook and Twitter or by E-Mail. 
Tuesday and Wednesday are usually the best days for this activity. 

Conclusion
Since the arrival of EPUB export functionality with Apple Pages 9.0.4 in 
August 2010, the production of our Smashing eBooks has become much 
easier. Now Apple Pages allows us to quickly export all three formats from 
one single source document and within a few minutes. We do not have to 
deal with HTML or CSS, and deep knowledge about EPUB and Mobipocket 
specification is not necessary.

We are looking forward to our Smashing eBooks further improving as the 
eBook technology advances. For instance the proposed EPUB 3 
specification will increase the eBook’s capabilities in order to better support 
a wider range of publication requirements, including complex layouts, rich 
media and interactivity. It is also likely that with this new specification EPUB 
will become the dominating eBook standard, meaning that the other two 
formats (PDF and Mobipocket) will become less and less important and can 
be eventually dropped. There are already some rumors that Amazon will 
begin accepting digital files in the EPUB format in the near future and will 
also allow users of its Kindle device to read EPUB files.

Smashing eBook│How to Produce an eBook│ 22

http://www.thebookseller.com/news/amazon-accept-epub-files.html
http://www.thebookseller.com/news/amazon-accept-epub-files.html
http://www.thebookseller.com/news/amazon-accept-epub-files.html
http://www.thebookseller.com/news/amazon-accept-epub-files.html

